Wednesday, November 26, 2014

RAC,Linux -- asm libraries , Do we need to install asmlib, ASM kernel driver and ASM support in OEL6?

Normally, there are 3 packages which need to be installed in Linux environment that will run Oracle ASM.
These packages are;

oracleasm (The kernel driver)
oracleasmlib (ASM libraries)
oracleasm-support  (ASM Support scripts)

We normally install these one by one, and use our ASM instances in our RAC environment accordingly.
On the other hand; I have realized that the things are a little different, when you use Oracle Enterprise Linux 6 for your RAC environment.
There are 3 facts for a RAC installation based on an Oracle Enterprise Linux 6)

1)The oracleasm kernel driver is built into the Unbreakable Enterprise Kernel for Oracle Linux 6 and does not need to be installed manually.
2)oracleasm-support can be choosed while installing Oracle Linux 6, so we do not need to install it manually.
But if we want to install it manually; the oracleasm-support package can be downloaded from the Unbreakable Linux Network(ULN) if you have an active support subscription, or from if you do not.
3) The oracleasmlib packages still need to be installed manually, it can be downloaded from  "" -> 

Intel EM64T (x86_64) Architecture

No comments :

Post a Comment

If you will ask a question, please don't comment here..

For your questions, please create an issue into my forum.

Forum Link:

Register and create an issue in the related category.
I will support you from there.