Wednesday, July 23, 2014

Oracle ADF-Browser Certification

It seems ADF is delicate when it comes to the Browsers :)

Nowadays, these ADF applications are popular in EBS world.. On the other hand, even if your EBS runs smoothly in your Browser, the integrate ADF application may produce errors..These errorrs/problems may vary .. Your ADF application may not able to bring any data in to your screens, or it may report an error, or it may not even function at all.
So in order to prevent these kind of problems, you need to know the ADF version which has support for your Browser, and install the proper version of ADF in order to be in safe side..
I share ADF - Browser certification in this post, because I didnt see any ADF releated requirements in Oracle Installation documents.. For example: Hr Organization Chart.. In HR organization chart implementation document , Oracle does not mention any browser requirements related with ADF.. In that document, you only see that ADF 11.1.1.4 or later is required for HR Org Chart application..
So when it comes to the real life, you may end up with errors while using your ADF applications..
The errors may arise because of your ADF release.. Actually the lack of the needed Browser support in your ADF release.
ADF Faces is important component, and it can be used as a reference for ADF-Browser Support matches ..

The Oracle ADF Faces rich client components supported with the following browsers.
Supported BrowsersADF Faces
Firefox 2.x, 3.x 2, 4+5Supported
Internet Explorer 7, 8 2, 9 5, 107, 117Supported
Safari (desktop) 3.2, 4.x 2, 5.x 4, 6 7Supported
Safari (iOS) 4.32, 56, 67, 77Supported
Chrome 1+ 1Supported
Chrome (Android) 18+ 7Supported
 Notes:
  • IE 11 support added as a post-release certification on 11.1.1.7.0. IE 11 support requires a patch from Oracle Support (patch #18277370 for 11.1.1.7.0)
  • The minimum required Firefox version is 2.0.0.20
  • For the ADF Faces components that render in Flash, Flash 9 and Flash 10 are certified until 11.1.1.4.0 from which point only Flash 10 is certified.
  • For Internet Explorer 8, 9, and 10, only Native mode is supported. View Compatibility mode should be disabled.

-------------------------------
1. Support or certification added in 11g Release 1 (11.1.1.1.0). Does not apply to 11g versions prior to 11.1.1.1.0.
2. Support or certification added in 11g Release 1 (11.1.1.2.0). Does not apply to 11g Release 1 versions prior to 11.1.1.2.0.
3. Support or certification added in 11g Release 1 (11.1.1.3.0). Does not apply to 11g Release 1 versions prior to 11.1.1.3.0.
4. Support or certification added in 11g Release 1 (11.1.1.4.0). Does not apply to 11g Release 1 versions prior to 11.1.1.4.0.
5. Support or certification added in 11g Release 1 (11.1.1.5.0). Does not apply to 11g Release 1 versions prior to 11.1.1.5.0.
6. Support or certification added in 11g Release 1 (11.1.1.6.0). Does not apply to 11g Release 1 versions prior to 11.1.1.6.0.
7. Support or certification added in 11g Release 1 (11.1.1.7.0). Does not apply to 11g Release 1 versions prior to 11.1.1.7.0.


Also, You should check Oracle Support's Certification tab.. Look for Oracle Application Development Runtime..

Here is an example of certification info related with ADF 11.1.1.6.0

,

Note that: There is no Browser certification information of ADF 11.1.1.7.0 on Oracle Support.
But I can say that , especially for IE 10, ADF 11.1.1.7.0 should be used.

No comments :

Post a Comment